Jump to content


Photo
- - - - -

SpeedLink Black Widow (SL-6640) Vibration issue


  • Please log in to reply
6 replies to this topic

#1 4zrael

4zrael
  • Posts: 1

Posted 06 December 2009 - 11:13

I've got a SpeedLink Black Widow Joystik, which doesn't feature real Force Feedback but Vibration Effects.

I already noticed in the trial, that when I leave Force Feedback enabled (which worked with Il-2 Sturmovik for example), I had a delay of at least 10 seconds, when doing anything ingame. So if I push a button such as E to start the engine , it will take a good time, till the command will be executed. The game is running fluidly, it's not a performance issue.
Also the vibration already starts while loading the mission and does never stop again. So it doesn't work properly.

In the trial I solved the problem by deactivating Force Feedback in the menu. But after buying the game and the newest patch, deactivating won't work anymore, I still get the never-ending vibration.
I could just solve it by uninstalling the driver, so the vibration doesn't work at all.

So my question is, if there's any possibility to get the vibration effetcs work correctly? It would be a shame, if I couldn't use them.
So if anyone has the same joystick and could get it to work properly, I'd really like to know how.
Looking forward to replies.

4zrael
  • 0

#2 Devere

Devere
  • Posts: 441

Posted 26 June 2010 - 15:38

Bump for an old post and an old problem!!

Just got one of these to try flying back to front, and have the exact same problem, yet the stick is spot on in every other sim. The software driver the stick installs is pretty bascic and no help, but its only RoF that has this problem.


It actually starts vibrating as soon as the game is loading!
  • 0

#3 BSS_DrGlow

BSS_DrGlow
  • Posts: 561

Posted 26 June 2010 - 23:23

Is this related somehow windows 7 and MS Sidewinder FF2
  • 0

#4 Devere

Devere
  • Posts: 441

Posted 27 June 2010 - 01:27

Cheers for the thread DR Glow, unfortunately its not the dreaded stutters.

Basically the vibration feature is on full time, and so far only in RoF. As stated it actually starts vibrating during mission load and does not stop until you exit the mission.

So far every game I've tested it with, it has behaved as I imagined it would. Just the game I bought it for does not :x

Bit more testing: I have found OFF also has the stick on permanent vibrate when flying. Does not start during load screen however.

So out of 3 ww1 sims, 2 make the stick vibrate constantly, only first eagles works as advertised.
  • 0

#5 Han

Han
  • Developer
  • Posts: 6670

Posted 29 June 2010 - 15:54

SpeedLink Black Widow (SL-6640)?
It's Very-Very-Very looks like a mistake in this Joystick model software/hardware. Looks like it's interpret the "Constant Force" effect as "Shaking".
So only way - is to turn off the Force Feedback or ask for support from Joystick developers.

  • 0

#6 Kumpel

Kumpel
  • Posts: 3

Posted 06 August 2011 - 23:24

Common guys at 777 Studios, please give us a break, this joystick works perfectly with any other piece of software except for yours. May be you need to contact SpeedLink for answers (this is what everyone else does to make sure their games work) rather than asking hudreds of people to bombard the manufacturer with undefined questions.
  • 0

#7 Danangleland

Danangleland
  • Posts: 2

Posted 20 August 2011 - 20:07

Hi, I am a new owner (starting today) of both a Speedlink Black Widow and Rise of Flight. I too experienced the problem with immediate and constant joystick vibration on loading of the game, and I found that simply uninstalling the drivers that come with the joystick worked. That might sound as if the stick wouldn't work, be recognised or have full functionality with games anymore, but it doesn't seem to be the case for me; perhaps Windows' drivers are enough. In any case, it may be worth trying if you haven't already. To clarify: I put the Speedlink driver CD back in my machine once it was already installed. Choosing the 'driver' button on the subsequent Autorun window, I was given the options of modifying the existing installation or uninstalling, and I chose uninstall. I reloaded Rise of Flight (didn't unplug the stick during any of this uninstalling procedure by the way) and was able to play, with no calibration or anything necessary, and no vibration at any point in the game. I have only played through the first three and a half missions of the tutorial campaign, but with all the basic controls working (throttle, rudder, stick banking and pitching, trigger for gun) it would seem the stick is fully functional.

My OS is Windows 7 Home Premium, 64 bit.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users