Jump to content


Photo
- - - - -

Trigger Spawner and Command Formation.


  • Please log in to reply
11 replies to this topic

#1 Zooropa_Fly

Zooropa_Fly
  • Posts: 878

Posted 26 September 2017 - 23:55

Would I be correct in thinking that these two things are effectively incompatible in the Mission Editor ?

 

:icon_e_salute:

ZF.


  • 0

#2 Deciman

Deciman
  • Member
  • Posts: 67

Posted 27 September 2017 - 14:45

Hm, no...

But a delay is needed between these 2 commands (at least 2 seconds I think, sometimes even more)
because before a unit can receive a command (whatever command) it has to be online (spawned)
and that might take some time...

 

Deci


  • 0

#3 Zooropa_Fly

Zooropa_Fly
  • Posts: 878

Posted 27 September 2017 - 15:10

Thanks for the reply Deci,

 

Thing is when I copy the example of ref 9.2 in the ME Manual (minus the formation changes which weren't needed for my test) things work just fine.

But as soon as I introduce a 'Spawner' for the planes - only the lead plane behaves orderly while the other two just circle obviously not getting the 'Formation' command nor being beckoned by the waypoint. That's with 3 seconds between each process.

The other two planes can be made to obey the waypoints by OLing 'Formation' and the waypoints to them (as opposed to just the lead plane) - but this effectively makes each plane it's own formation and liable to collisions if not spaced out enough.

I get the same experiences with vehicle columns - they either form up or respawn, but never both.

 

I've looked at a few existing missions and I haven't yet come across anything I think works...

 

:icon_e_salute:


  • 0

#4 Deciman

Deciman
  • Member
  • Posts: 67

Posted 27 September 2017 - 18:46

Delay between 'Waypoint' (leader only)
and 'Formation' set?

IIRC a new waypoint might set the formation inactive...

Deci

 

PS: And as only the leader gets the waypoint and the other 2 planes not
it seems the the plane themselves are not propperly linked (wingmen T-linked to the leader)


  • 0

#5 Deciman

Deciman
  • Member
  • Posts: 67

Posted 27 September 2017 - 19:22

Just checked my own mission...

Wingmen T-Linked to the leader

Waypoint O-Linked to the leader

Formation O-Linked to the leader

 

Planes Spawn

2 sec delay -> Waypoint triggered
4 sec delay -> Formation triggered

 

Next waypoint same delays for both, Waypoint and formation

 

Deci


  • 0

#6 Zooropa_Fly

Zooropa_Fly
  • Posts: 878

Posted 27 September 2017 - 22:39

Hey Deci thanks for your time.

 

See attached screenshot for a basic formation I just tried - 3 Alby's set to spawn after 3 seconds and head for waypoint 1 over Courcy, then on to waypoint 2 at the front.

 

The way I read it -:

2 seconds after Spawning waypoint 1 is triggered calling the lead plane to it.

2 seconds later the Formation command tells the lead plane to form up in a 'safe' V formation.

So at this point I'd expect all 3 planes to be heading for waypoint 1 in a V form, since planes 2 and 3 are targeted to the lead plane.

Once waypoint 1 is triggered, waypoint 2 should call the lead plane, hence the other two should follow.

All three should fly in circles once waypoint 2 is triggered as they have no further instruction.

'On Killed' as a group the Counter re-activates the 3 second timer and the process should start again.

 

What's actually happening is plane 1 seems to be following the intended path, but 2 and 3 are circling around their spawn point - not forming up and not heading to the waypoint.

 

The last sentence of your previous post seems to differ from what I've done - if you are able to have a look maybe you could suggest a fix now that you've seen my effort...

 

:icon_e_salute:

ZF.

 

Attached File  Formation.jpg   317.96KB   0 downloads


  • 0

#7 Arty_Effem

Arty_Effem
  • Member
  • Posts: 572

Posted 27 September 2017 - 23:40

Would I be correct in thinking that these two things are effectively incompatible in the Mission Editor ?

 

 

It is known that links between dynamically-spawned vehicle groups are ignored.

If you enjoy wasting your time you could file a bug report, enclosing a screenshot of the pertinent MCUs and also a screenshot of your explanation Google-Translated into Russian.


  • 0

ARTY EFFEM


#8 Zooropa_Fly

Zooropa_Fly
  • Posts: 878

Posted 28 September 2017 - 06:54

It is known that links between dynamically-spawned vehicle groups are ignored.

If you enjoy wasting your time you could file a bug report, enclosing a screenshot of the pertinent MCUs and also a screenshot of your explanation Google-Translated into Russian.

 

There'll be no 'ticket' submitted - enough time wasted already !

I suspect less chance of getting the ME updated than the game itself - so that's a negative something.

It feels very much like a v1.0 which should by now be up to v4.3 (min / max'ing the window to get rid of the blocky pixels isn't funny anyomre).

 

Anyway, reg. spawning formations - thought I'd read something about an issue with this, maybe an old post of yours..

 

But if anyone knows of a work around...

 

:icon_e_salute:


  • 0

#9 Deciman

Deciman
  • Member
  • Posts: 67

Posted 28 September 2017 - 12:57

There is one thing you can try...
Add another timer (6 sec) to 'command Cover'

Cover is O-Linked to the wingmen and T-Linked to the leader.

Maybe that helps to keep them close together even without them having a formation.

 

Deci

 

PS: You can also attach the mission (or the group only) as a file here

so that I can have a closer look.


  • 1

#10 Zooropa_Fly

Zooropa_Fly
  • Posts: 878

Posted 28 September 2017 - 13:31

Ok thanks Deci - unfortunately it's telling me I'm not allowed to upload such files to the forum.

 

I'll go and try a 'Cover' command, tried it once before to no effect but will give it a go with this formation.

 

Thanks again,

:icon_e_salute:

ZF.


  • 0

#11 Deciman

Deciman
  • Member
  • Posts: 67

Posted 28 September 2017 - 13:44

Ok thanks Deci - unfortunately it's telling me I'm not allowed to upload such files to the forum.

 

Try it with a '.zip' containing all files from the mission/group

 

Deci


  • 0

#12 Zooropa_Fly

Zooropa_Fly
  • Posts: 878

Posted 28 September 2017 - 15:55

UPDATE !

 

Deci - the 'Cover' command seems to be working :icon_eek: .

The inclusion of the 'Formation' command still makes no difference to the planes' behaviour in this layout.

So the only difference to the above jpeg is putting 'Cover' in place of 'Formation' (with appropriate linkage), and I used a 10 second timer.

 

The covering planes are flying ahead then circling until the lead catches up, I assume that's the expected covering tactics - but they're all essentially following the waypoints whilst observing this covering ritual.

I varied the altitudes slightly for a bit of vertical seperation

 

So I'll settle for that as a decent work around !

 

Muchos Gracias,

:icon_e_salute:

ZF.


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users