Jump to content


Photo
- - - - -

"MASTER - SERVER" FIX for Error #2 and #1 (Please do not post a reply)


  • Please log in to reply
3 replies to this topic

#1 Plank

Plank
  • Posts: 2835
  • LocationNew Zealand.

Posted 03 April 2015 - 15:59

READ ONLY! DO NOT POST A REPLY. (Respect this please!) .

 

I will try to sort out what happened.

I am not sure exactly how this was resolved.

I will check in here with info periodically.

 

PLEASE DO NOT POST HERE.

 

 

I do not want to start ANYMORE discussions.

(It's a bloody mess as it is. all my fault. Damn it.)

 

The DIRT:

 

My copy of RoF refused to connect to the 'MASTER - SERVER"  and errored with #2 an underneath that #1. (it went on for tooooooooooooooooo long)

 

I discovered through banging my head on the wall that the RoF server was not responding using the secure communication protocol. (SSL)

 

(Search for these  SSL/TLS hand shaking etc SSL certificates etc etc etc there is a LOT to learn)

 

the issue was NOT

 

ports

DNs servers

active virus's

Virus scanners

HDD fragmentation

Cables

Wifi

Port forwarding etcetera

 

What I suspect and will UPDATE when I get PROOF is that FOR SOME REASON my PC did not have the SSLv1 protocol enabled.

 

I might be WRONG.

 

And, the master-server had expired SSL certificates (is this the real problem?, I do not know)

 

I have to do some extensive working backward to see how his was FIXED. I am not looking forward to it. (cute pun)

If you have questions PM me. I will try to respond. (DO NOT SPAM ME!!!)

 

A possible reason that this happened:

 

A virus that had been removed from my system and had taken the SSLv1 with it. OR broke it. (yes SSL is heavily attacked)

 

I think I reinstalled SSLv1 and the master-server issue was fixed.

 

This is a THEORY. There is not proof yet, and may never be.

 

I will POST a REPLY  to this thread when I get news.

 

Please do not reply to this thread. Leave it clean and simple for people  to LEARN from.

 

PM me if you  need to. I am quite approachable.

 

 

S A L U T E !

 

Plank.


  • 1

-

Captured again!

 


#2 Plank

Plank
  • Posts: 2835
  • LocationNew Zealand.

Posted 03 April 2015 - 16:12

STEP ONE.

 

Download wireshark.  from here:

 

https://www.wireshark.org/

 

STEP TWO

 

Load up wire shark

 

STEP THREE

 

Load up ROF and get to the login part.

 

STEP FOUR

 

Start Wireshark recording

 

STEP FIVE

 

Punch in your details into the RoF login and try to connect.

 

STEP SIX

 

When RoF errors and you see #2 and then #1 quit out 

 

STEP SEVEN

 

stop Wireshark recording.

 

STEP EIGHT

 

You now need to read the wireshark log which is in front of you.

 

STEP NINE

 

If you see a line that looks like this:

 

Attached File  ComputorSaysNo.jpg   94.24KB   1 downloads

 

and there is NO: TLSv1 SERVER HELLO

 

Then you have a problem.

I am guessing that you do not have TLSv1 protocol enabled on your PC. (this might not be the case but it looks like it is)

 

STEP TEN

 

Make a cup of tea,  you are now a sysadmin. (your own)

 

You have discovered a problem on your system ,it might not be the only one and it might not actually be THE problem.

 

But,  I do know this for sure:

 

If you cannot create a SECURE SOCKET LAYER

 

http://en.wikipedia...._Layer_Security

 

you cannot login and authorise RoF etc or play online or offline. (authorisation has to happen after you down load RoF_UE)

 

Plank. (I cross my fingers every time)


  • 1

-

Captured again!

 


#3 Plank

Plank
  • Posts: 2835
  • LocationNew Zealand.

Posted 03 April 2015 - 16:40

OK I installed this:

 

https://www.smartftp...ws-7-f2679.html

 

I AM NOT SUGGESTING YOU DO THE SAME.  I AM JUST SAYING THAT IS WHAT I DID. ( I didn't even scan it, I was tired)

 

I did open a menu in Win7 which listed all the SECURITY protocols but I cannot find it again yet. (who designed this rubbish GUI?)

and TLSv1 was NOT on the list. so I followed my nose found the above page and then fell asleep at the wheel.

 

Plank.

 

EDIT:

 

This is a registry entry which re enables TLSv1 etc.  so that makes me think that TLSv1 was "turned off".

(a virus could do that to force the use of SSLv2  as it not very good and easy to break into)


  • 1

-

Captured again!

 


#4 Ravindu_Shashika

Ravindu_Shashika
  • Posts: 45

Posted 16 August 2015 - 23:29

 

I got the same problem and I SOLVED IT. Reason for the problem is 443 and 80 ports are not enabled and u have to enable them. To do that you have to goto your Firewall.

1.Open Windows Firewall by clicking the Start button , clicking Control Panel, clicking Security, and then clicking Windows Firewall.

2.Click Allow a program through Windows Firewall. ...

3.Click Add port.

4.In the Name box, type a name that will help you remember what the port is used for.
5.Then make a TCP port for 443.
6. Then do same for port 80.
 I'm no using windows firewall and I'm using my Virus Guard's one. So I have to add ports in my V.Guard.
 
 
 

  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users