Jump to content


Photo
- - - - -

Help with damage on static planes and objects


  • Please log in to reply
4 replies to this topic

#1 Mertons

Mertons
  • Posts: 72
  • LocationSpain

Posted 02 March 2015 - 20:53

Hi there!

 

I've been working hard with ME to create MP missions for my squad, and in the last one (bombing run over an airfield with static planes from Lefuneste mod) we noticed that although bombing was successful with some direct hits, none of the blocks showed any damage. In the description of the mod I can read that that static planes are supposed to change thier texture to the damaged one when durability points are zeroed, so I decide to create a quick mission to investigate. The result is that I can't make any object (static planes, buildings or other blocks) to show damage. 

I have checked they have linked entity (tested all nationalities with no joy), and the send "On Damage" and "On Killed" messages so a truck launched flares and subtitles apeared, but no visual change.

In fact, I'm not able to place a block or building and change the damage level, because when I add the id and the amount (1) in the damage label of object properties. it disappears when deselecting the block, so I cannot even put the same destroyed bridge than in page 39 of the mission editor manual.

So, what am I missing or doing wrong?

 

Thanks in advance


  • 0

#2 Mertons

Mertons
  • Posts: 72
  • LocationSpain

Posted 05 March 2015 - 14:36

Ok, so I kept on investigating while I waited for some help (no luck for me :icon_e_deadman: ), but with no success. I discovered in old posts of the forum that not all buildings and blocks are destroyable, so I wonder if there is a list of destroyable buildings I can use to bomb or straffe (I suppose there isn't). But in case there is one, I'm still stuck in why I cannot add damage to those blocks in their properties tab.

Another point I'm trying in ME is using the Command:Damage: as I stated that linked entitied blocks do send "OnDAmaged" and "OnKilled" messages, I'm trying to use this command to "destroy" the blocks (or Lefuneste static planes) when the message or event is recieved, same way that posting subtitles or launching flares (my best achievement until now).

 

Last posibility (and not tested for now) is trying to delete the block I want to be destroyed by bombers through Command:Delete, but I remember that sometime ago I read on the forum that this command was not applicable to blocks, so maybe could I use  Command:Deactivate instead? It wouldn't be the best option, but my squadmates would know how many targets are still left to be attacked.

 

And final question: can all my problems be related with not setting the primary and secondary objectives of the mission from the beggining? I was following the ME lessons on the old website, but I hadn't reach that point when it went to maintenance mode, and now they are not restored.

 

So please, Great Lords of Mission-Making, light this poor apprentice with a bit of your Sapience, my fellow pilots will thankyou forever  :icon_lol:

 

:icon_e_salute:


  • 0

#3 Genius

Genius
  • Posts: 587

Posted 07 March 2015 - 10:14

Sometimes i have the same bug in Mission Editor and single player.

 

Maybe the solution is: Supress mission editor folder (bin editor) and do a recovery


  • 0

#4 Mertons

Mertons
  • Posts: 72
  • LocationSpain

Posted 11 March 2015 - 07:30

Sometimes i have the same bug in Mission Editor and single player.

Maybe the solution is: Supress mission editor folder (bin editor) and do a recovery


It partially worked, so thanks a lot! I think that my ME got bugged or corrupted on v1.035 or 1.036 patching, so all missions created in that period seem not to present the damage. The curious patt is that after loading a bugged mission (the one I was using for testing, for instance), all new missions I start from scratch will be bugged too; but If load a damage-working mission (Lefuneste's static planes mod testing mission, for example), all new missions and templates will also work.
So, my suggestion for people with same problem is to backup a mission or template on which you can add damage to blocks or buildings via mission editor, and use it as a "loader" for creating bug-free new ones.

Regards, and thanks again!
  • 0

#5 Genius

Genius
  • Posts: 587

Posted 11 March 2015 - 21:12

Thanks too, i will try your tips if this bug reappear  :icon_e_salute:


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users