Jump to content


Photo
- - - - -

Model animation issues


  • Please log in to reply
1 reply to this topic

#1 ImPeRaToR

ImPeRaToR
  • Posts: 7902

Posted 23 February 2013 - 15:44

Maybe we can collect all issues we run into in this thread and try to help each other with them. One issue almost drove me crazy just now:

WARNING: Animated node <name> has ununiform scaling for PIVOT
Specified model object has pivot that is scaled along one or more axes. This may lead to incorrect rendering or animation of the object in game. You should normalize the pivot for this object by using Reset Scale command from Hierarchy tab or Reset XForm from Utilities tab.

The piece in question had several children. Upon resetting, one child would be distorted and bent and I assumed it was the fault of the child, not the parent. Took me a while to realise that I had to unlink everything first before I can use Reset XForm but once I had done that I could link all objects together again. However I had to redo the animations for the one object that had the ununiform scaling issue in the first place but not much of a biggie.
  • 0

#2 SQSN

SQSN
  • Posts: 85

Posted 11 March 2013 - 15:37

Don't do anything. It's just a warning, not an error. This message always happens with muzzle flash object on planes. Yet, in-game everything works fine.
I guess, your object in question is also a standard muzzle flash. That's how it was made originally by NeoQB, 777, or whatever they are called now. It's their sloppy work, so put all blames on them. :lol:

PS. This actually happens every time, when your objects have scale animation. The export plugin still gives you a warning, though everything is there as it should be.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users