Jump to content


Photo
- - - - -

About the Sound Bug


  • Please log in to reply
2 replies to this topic

#1 Jason_Williams

Jason_Williams
  • Producer
  • Posts: 3468
  • LocationLas Vegas, NV USA

Posted 28 December 2012 - 18:24

Guys,

First, we are aware of the issue. Due to the Holidays and the chaos of the update release itself, it has taken us longer than usual to have our usual meetings where we discuss bugs etc.

After talking to the team about it, it appears that we can replicate a sound problem in SP, which luckily doesn't seem to happen to users very often, but the MP bug is proving more complicated to solve. We're not sure if that both bugs are one in the same though. However, we think the problem may be with the FMOD sound engine itself and not our code per se. We do some pretty big things with our sound, so maybe we have pushed the FMOD to the breaking point. Or maybe some change to some other part of the game unexpectedly affected the sound. You guess is as good as mine, but we will work to fix as we always do. It's going to take more investigation and probably talking to the FMOD folks about it before it gets fully resolved.

Unfortunately, at this point we don't have any workarounds or other suggestions to minimize it. If anyone in the community sees a workaround or a clear way to reproduce in MP please let us know. If something turns up I will let everyone know.

We of course, apologize about the issue, but because we constantly update the game and add more things to it, bugs can happen. No one is happy about it believe me and it's embarrassing. We also try to address such issues publicly as soon as we have a clearer picture on what is happening. Making over the top demands of us in a public manner does nothing to improve the situation. Bug are an unfortunate part of software development. You can still enjoy this ROF update for the most part and based on the reaction from the community you are, minus the sound bug.

After 3+ years of public development and 30+ updates there is zero need to be dramatic about this. When a nasty bug like this appears or a known bug worsens, we will obviously work to fix it as soon as we can. I know of no other team in flight-sim history that has done so much to "officially" improve their product.

Again, we are sorry for the inconvenience this bug has caused our community and we will work to fix.

Jason
  • 0

#2 Jason_Williams

Jason_Williams
  • Producer
  • Posts: 3468
  • LocationLas Vegas, NV USA

Posted 16 January 2013 - 20:34

Update: We think we are making progress on this based on work we have done in the dev. office since Xmas. We hope to start testing our possible solutions soon. If they work we will put out a hotfix asap as we usually do.

Jason
  • 0

#3 Jason_Williams

Jason_Williams
  • Producer
  • Posts: 3468
  • LocationLas Vegas, NV USA

Posted 24 January 2013 - 06:14

Fixed in 1.029b.

Jason
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users