Jump to content


Photo
- - - - -

Disable Bandwidth Throttling in Windows Vista and Win 7


  • Please log in to reply
2 replies to this topic

#1 Bump

Bump
  • Posts: 141
  • LocationColorado

Posted 11 February 2012 - 12:55

I just discovered this and it worked very well for my situation.

Since I'm on a fixed wireless connection, being that I live in the country and always thinking that my provider was throttling down my bandwidth, and because I was getting disconnected and had some bad lag when there was heavy traffic in my area playing ROF multiplayer.

Apparently windows Vista and Windows 7 reserves about 20% of your bandwith for automatic downloads for windows update, multimedia player, audio, other stuff I'm not sure of, because I'm not a tech and know just the basics of computers, but very determined to resolve my connection problems.

Videos streaming works great now with no loading pauses and Playing Rof in multiplayer runs smoother, consisted FPS and no timeouts or disconnection from game.

The first one we are going visit is bandwidth throttling. This was introduced in Vista and subsequently leaked over into Windows 7, continuing to cause many people grief. Open your registry editor by running regedit from the Start -> Search programs and files field. You should be an administrator of the system you are doing this on. We now want to browse to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters

Once there, a new DWORD value needs to be created called DisableBandwidthThrottling. Create that value and double-click it to open it for editing. Change the Base radio button to Decimal then change the Value data entry to 1. Click OK to accept the new value.

Now, I recommend you go ahead and reboot at this point and once getting back to your Desktop, try streaming a file that has always been troublesome before. If you stream without choppiness, stutter or skipping, you’re problems are solved and you can end here. If you are still experiencing trouble, continue on and try the next registry change.

Next (re-open your registry editor if not already opened), let’s browse to:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile

and locate the NetworkThrottlingIndex DWORD entry. Double-click it to open and change the Base to Decimal. The default value for this DWORD is 10, but the valid range for it is 1 to 70. You can try lower values than 10, but I want to start off with totally disabling by using a value of 1 in the Value data field. Click OK to accept and reboot once more. Upon returning to your Desktop, try streaming a troublesome file once again to see if it plays back properly. If so, you should be good to go and can repeat this process on any other Vista/Windows 7 systems on your network that pose a problem.

If this doesn’t resolve your issues, you could also try disable Remote Differential Compression. Other than that, it may take some additional troubleshooting to find the root of your problem.

This may already been discussed, but I figured I'll throw it out there anyway.
:S!: Bump
  • 0

#2 boogar

boogar
  • Posts: 40

Posted 20 February 2012 - 05:18

Thank you for the info.I also keep one eye on my internet sevice provider and that's helped me out in the past alot.I also have low bandwidth issues in my area and make sure I'm running at 3.0 all the time like I pay for.
The issues with windows 7 I was unaware of but will fix asap.
Thank you for the help…
  • 0

#3 ZaltysZ

ZaltysZ
  • Posts: 1638

Posted 20 February 2012 - 07:23

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters

Once there, a new DWORD value needs to be created called DisableBandwidthThrottling. Create that value and double-click it to open it for editing. Change the Base radio button to Decimal then change the Value data entry to 1. Click OK to accept the new value.

That BandwidthThrottling is supposed to help in avoiding timeouts while using Shares over high latency networks. Microsoft is a bit vague about this, but I think it affects only Shares (i.e. transferring files).

Next (re-open your registry editor if not already opened), let’s browse to:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile

and locate the NetworkThrottlingIndex DWORD entry. Double-click it to open and change the Base to Decimal. The default value for this DWORD is 10, but the valid range for it is 1 to 70. You can try lower values than 10, but I want to start off with totally disabling by using a value of 1 in the Value data field.

That value sets at what maximum rate to process non multimedia traffic when there is multimedia traffic present. Units are packets/ms. Hex value of FFFFFFFF disables it completely. Idea behind it is that multimedia traffic should have priority, because it is usually time sensitive and can't wait (or you may see freezes, skips, delays and so on). This throttling helps multimedia traffic by limiting non multimedia traffic, and it is only active when multimedia programs are being run.

Changing this you may win something, but may loose something too. If you are watching youtube and sending a file via Skype or other IM, this throttling should help in smoother youtube play. On other hand, if you have youtube or some sort of internet radio playing in the background while you are gaming, game may suffer from warping.

If this doesn’t resolve your issues, you could also try disable Remote Differential Compression.

Unless you have speed problems with Shares, Remote Differential Compression should not be blamed. It is used to trade higher CPU/IO usage for shorter transfer time, when you need to frequently update files over slow networks.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users