Jump to content


Photo
- - - - -

Attention ATI Users with Stutter. Please Read.


  • Please log in to reply
111 replies to this topic

#1 Jason_Williams

Jason_Williams
  • Producer
  • Posts: 3468
  • LocationLas Vegas, NV USA

Posted 04 September 2011 - 23:22

Ok guys,

Some, but not all ATI users are complaining of stutrers with 1.021. To make sure I built an ATI Crossfire capable system and stutters appeared. We don't know the cause of this nor do we know why some get them and some don't. The guys in our office do not get them so more investigation is needed. But in the meantime, if you get these stutters try the following stop-gap measures. This should allow you to play the game with reasonable performance until we solve this issue.

My system is:
Intel i7 920 at 3.2 GHZ
6GB RAM
ATI 6770
Sound Blaster X-Fi
7200 RPM HDD 2TB

I'm running 11.8 drivers.

1. Keep your ATI settings at benign default settings to not add any more stress to ROF rendering.

2A. Option #1: Lock your FPS at 30 and check on SLI/Crossfire box even if you have a single ATI card. Some users have been using the record function of FRAPS with frame lock on to limit frames to 30, but you do not need to do this, simply lock then in the ROF settings. My in game settings are this:

ROF_Settings_ATI.jpg

2B. Option #2: Uncheck Full Screen and run the game at a resolution smaller than your current native resolution. Some have reported this allows for smooth gameplay without the need to lock frames. I can confirm this also worked on my system.

3. If you have a Crossfire system and you have enabled Crossfire try locking your FPS at 50 in the settings. That should bring you smoother gameplay. You can also try 30, but 50 worked pretty good for me and allowed for pretty smooth gameplay and higher FPS.

Turning down your gaphics settings to super low is not really going to help. This is not the issue. Something else is causing the problem. Just try my suggestions above for best results. If they don't work for you, I am out of suggestions for the time being, but this is what worked for me.

That's all I can suggest at the moment. When we know more about a fix or a cause I will post it. I unfortunately do not have an ETA. Of course it is a top priority for our lead programmer.

However, a lot of this trouble stems from us being unable to talk to a qualified ATI engigeer. We have made low level contact with ATI through their arcane and clumsy developer area of their website, but they have ignored our urgent requests to talk to their engineers directly. A similar situation happened with NVIDIA, but once we made contact they made it right and sent us some non-public documentation that solved our problems with NVIDIA cards. We wish ATI would wake up and do the same.

As soon as we know more I'll post.

Jason
  • 0

#2 kirock777

kirock777
  • Posts: 1138

Posted 04 September 2011 - 23:38

Thanks so much, Jason.
I'll be giving your suggestions a try this evening and will report back later. :)
Good luck with the AMD issue… if they want to keep their customers, they need to listen.

Thanks again for really supporting this community! :S!:

Edit: And thanks for the specs! :-)
  • 0

#3 1PL-Sahaj-1Esk

1PL-Sahaj-1Esk
  • Posts: 940

Posted 05 September 2011 - 00:34

Thats really weird … why does AMD keep ignoring your requests to contact them. I mean it is one of the best sims if not the best sim out there and it is a perfect place to advertise their product to make their cards look competitive to Nvidia's but what do they do ? they are on a good way to mess it up really hard.

I just simply dont get it ! freeeks :x
  • 0

kpt. pil. / Capt. Sahaj / Operations Officer / 1. Eskadra Mysliwska / 1. Pulk Lotniczy / http://www.1pl.boo.pl

bannerf11esks.png?raw=1

http://warthog-extensions-by-sahaj.com


#4 Jason_Williams

Jason_Williams
  • Producer
  • Posts: 3468
  • LocationLas Vegas, NV USA

Posted 05 September 2011 - 00:46

Thats really weird … why does AMD keep ignoring your requests to contact them. I mean it is one of the best sims if not the best sim out there and it is a perfect place to advertise their product to make their cards look competitive to Nvidia's but what do they do ? they are on a good way to mess it up really hard.

I just simply dont get it ! freeeks :x

We've made contact with ATI, but only at the lowest possible level. Basically some low level email support jockey says, thanks for your message, we'll get back to you. Their entire developer outreach part of their website is unclear and arcane and not helpful to my team. Meanwhile I've explained the problems we have with ATI hardware to them in several messages that we need some expert guidance to solve some of these issues that their public documents do not cover. Also, a senior manager at NVIDIA even called ATI on our behalf and sent an email to one of their engineers only to get no response.

So we're frustrated as hell and if so many of you did not buy their stuff we'd drop supporting them all together at this point.

Jason
  • 0

#5 SYN_Haashashin

SYN_Haashashin
  • Posts: 384

Posted 05 September 2011 - 01:05

Hey Jason, I understand you are piss off with ATI, I am too, even I am one of those ATI users with no problems. Just reading you would drop supporting them if it wasnt for us the ATI user, I am going to send an email to this guys telling them I am their user and have problems with the best sim out there just because they refuse to answer to you. I know it wont make a diference, but i am sure if they receive emails from all the ATI user of this community maybe at least they would take a look at it…and if they dont..I think is time to change to Nvidia ;).

Thanks for this great sim, keep it up.


Edit: Couldnt find an email on webpage, so in the morning here in Europe I will call to the national sales office in Madrid and they will listen to me… :x
  • 0

#6 DidNotFinish

DidNotFinish
  • Posts: 4454

Posted 05 September 2011 - 03:26

I will try these settings now. Thanks for the hard work Jason. I love 1.021 but I just need to iron out these stutters! 8-)
  • 0

#7 Jason_Williams

Jason_Williams
  • Producer
  • Posts: 3468
  • LocationLas Vegas, NV USA

Posted 05 September 2011 - 04:38

I will try these settings now. Thanks for the hard work Jason. I love 2.021 but I just need to iron out these stutters! 8-)

1.021 my friend.

Jason
  • 0

#8 paco7425

paco7425
  • Posts: 90

Posted 05 September 2011 - 04:51

Hello Flying brothers:


Computer still stuttering, even with 19% of video memory use; the only way to reduce stuttering was to reduce screen resolution form 1280x1024 to 1024x768, it worsened a little the image, but at least the stuttering allows me to play the game.

AMD Athlom ™ 7750 Dual Core Processor 2.70 Ghz, 8GB Ram, Windows xp 32 bits, video card ASUS EAh4350 series ATI Technologies inc.

saludos.

Attached Images

  • rof.jpg

  • 0

#9 DidNotFinish

DidNotFinish
  • Posts: 4454

Posted 05 September 2011 - 05:06

I will try these settings now. Thanks for the hard work Jason. I love 2.021 but I just need to iron out these stutters! 8-)

1.021 my friend.

Jason

:P Of course! Fixed! Although I'm sure 2.021 will be pretty great in its day too.
  • 0

#10 ZaltysZ

ZaltysZ
  • Posts: 1638

Posted 05 September 2011 - 05:45

My friend has ATI and he found that stutters are related to vsync and probably the internal FPS limiter. Disabling vsync and using external fps limiter made game smooth for him. Everyone with stutters, try running RoF without vsync (disabled in RoF and in Catalyst) and report the effect.
  • 0

#11 Jason_Williams

Jason_Williams
  • Producer
  • Posts: 3468
  • LocationLas Vegas, NV USA

Posted 05 September 2011 - 06:06

Turning off Vsync does not always solve the problem. It doesn't on my system. Use my technique above and things should improve.

Jason
  • 0

#12 Jason_Williams

Jason_Williams
  • Producer
  • Posts: 3468
  • LocationLas Vegas, NV USA

Posted 05 September 2011 - 06:07

Hello Flying brothers:


Computer still stuttering, even with 19% of video memory use; the only way to reduce stuttering was to reduce screen resolution form 1280x1024 to 1024x768, it worsened a little the image, but at least the stuttering allows me to play the game.

AMD Athlom ™ 7750 Dual Core Processor 2.70 Ghz, 8GB Ram, Windows xp 32 bits, video card ASUS EAh4350 series ATI Technologies inc.

saludos.

Like I said above, lowering graphics memory does not help things. Only limiting the frame rate or using windowed mode does.

Jason
  • 0

#13 D.Smith

D.Smith
  • Posts: 226

Posted 05 September 2011 - 06:25

My friend has ATI and he found that stutters are related to vsync and probably the internal FPS limiter. Disabling vsync and using external fps limiter made game smooth for him. Everyone with stutters, try running RoF without vsync (disabled in RoF and in Catalyst) and report the effect.

I tried that it did not solve the problem but limiting the frame rate does improve things a little. I will experiment with Jason's settings and see what happens.

:S!:
  • 0

"The problem with quotes on the Internet is that you can never know if they are genuine." --Abraham Lincoln (1864)


#14 Gwanchos

Gwanchos
  • Posts: 86

Posted 05 September 2011 - 07:02

Hi Jason

Please can you advise how I can start the game in offline mode WITHOUT updating to the new patch. I was able to do so until yesterday but then I accidently hit ONLINE logon. The game is now refusing to start unless I update. There must be a way to reset something. I just want to wait until this is sorted before patching rather that struggle with lowered settings.

Many thanks
  • 0

#15 J5_vonHippel

J5_vonHippel
  • Posts: 23

Posted 05 September 2011 - 07:41

Holy Crap Batman! No more ATI for me that´s for sure as long as they don´t shape up.
  • 0

#16 JoeCrow

JoeCrow
  • Posts: 4150

Posted 05 September 2011 - 08:06

Holy Crap Batman! No more ATI for me that´s for sure as long as they don´t shape up.

They're not doing themselves any favours and will lose customers PDQ. Word and reputations spread fast in gaming communities. It kinda slants my next GPU upgrade towards Nvidia.
  • 0

#17 Jason_Williams

Jason_Williams
  • Producer
  • Posts: 3468
  • LocationLas Vegas, NV USA

Posted 05 September 2011 - 08:44

Hi Jason

Please can you advise how I can start the game in offline mode WITHOUT updating to the new patch. I was able to do so until yesterday but then I accidently hit ONLINE logon. The game is now refusing to start unless I update. There must be a way to reset something. I just want to wait until this is sorted before patching rather that struggle with lowered settings.

Many thanks

You can't. Sorry Gwanchos. I know this is annoying.

Jason
  • 0

#18 Gwanchos

Gwanchos
  • Posts: 86

Posted 05 September 2011 - 08:59

Hi Jason

Please can you advise how I can start the game in offline mode WITHOUT updating to the new patch. I was able to do so until yesterday but then I accidently hit ONLINE logon. The game is now refusing to start unless I update. There must be a way to reset something. I just want to wait until this is sorted before patching rather that struggle with lowered settings.

Many thanks

You can't. Sorry Gwanchos. I know this is annoying.

Jason

Darn … ok thanks for ansa
  • 0

#19 Zent

Zent
  • Posts: 111

Posted 05 September 2011 - 09:05

thanks a lot Jason for your dedicated work and the open communication style, that is so refreshing and friendly. I have total confidence that you guys will eventually work it out, until then your suggestions are helpfull to have a reasonable gameplay, so dont hurry but make it right.

I am too getting kind of angry with AMD, my expensive 5970 is my second AMD card in many years and again, like already with the 9700 i have a technically great card but endless driver problems… i cant recall having even half the troubles with my Nvidia cards. So my bias in the future will be clear… but for now the card i have has to go for at least another two years… you know i cant buy a new card, i have to invest my money into buying planes and gauges :)
and i think it would be a bad business idea to basically exclude about half the potential new customers because they have the wrong card manufacturer.
But we all should storm their AMD forums and tell about the problem and how stupid they behave…maybe it will wake them up eventually..i will post there..somehow they must already be aware of the existence of ROF, because in Cat 11.7 they did include a ROf crossfire profile…so they know we are here…probably they thought in their holy arrogance that this should be sufficient…
  • 0

#20 Oldsimmer

Oldsimmer
  • Posts: 446

Posted 05 September 2011 - 10:28

My PC spec
Windows 7 64bit
intel 2500K
8GB RAM
Asus P8P67 M/B
HD 5850 Card
all drivers are upto date and the latest bios.

I have never ever had problems with any stuttering BUT the bigest hit for me is ANTIALIASING I have mine set at 2X any higher and my FPS drops very low.
Sorry can't post a pic of my settings the following are HIGH LANDSCAPE/GRASS/TREES/REFECTION/TEXTURE/SHADERS/ LIGHT SCOURSES 20 / FOREST VISIBILTY VERY FAR/ SHADOWS SPECIAL MED / LANDSCAPE MESH AND OBJECTS VIS 100%/ WITH POST EFFECTS ONLY HDR MED NO OTHER TICKED / FPS SET AT 60 / VERTICAL SYNC AND FULL SCREEN TICKED / AND MOST IMPORTENT FOR ME ANTIALISING 2X / SCREEN RES 1920X1200 (16:10)

And im not kidding it just flows so nice, sorry to rub it in guys.

The HD5850 has IGB MEM and this is the best card I have ever had one last thing I run COD and have no problems running that on high settings infact what ever I throw at it I have no problems.

Do try the Antialiasing.
  • 0

#21 Oldsimmer

Oldsimmer
  • Posts: 446

Posted 05 September 2011 - 10:38

Managed to take a screen shot you may notice I also run FSX ORBX and it runs that just great.

rof 2.jpg
  • 0

#22 W1ndy

W1ndy
  • Posts: 1475

Posted 05 September 2011 - 10:42

Remember a while ago that some MSSWFF2 sticks were causing stutter ?. I wonder if FF has anything to do with it.

I,ll fly with and without when I get back to my gaming PC tomorrow.
  • 0

#23 MarcoRossolini

MarcoRossolini
  • Posts: 2991
  • LocationMelbourne, Australia

Posted 05 September 2011 - 10:48

When(if) I upgrade my computer, I'll forget about using ATI stuff, more truble then they're worth it appears to me. Nvidia and intel seems to be the way to go…
  • 0

#24 Gwanchos

Gwanchos
  • Posts: 86

Posted 05 September 2011 - 11:10

This ATI bashing may be a little premature. Maybe we should wait and see what the DEVs find. Im pretty baffled that Jason seemed to suggest they only tested the patch on an ATI system AFTER release when he built a system himself to test the issues reported by us on. Surely testing updates on BOTH main types of GPUs in the community should be minimum requirement for BETA testing ?
  • 0

#25 bionic

bionic
  • Posts: 27

Posted 05 September 2011 - 11:26

thanks Jason
  • 0

#26 Zent

Zent
  • Posts: 111

Posted 05 September 2011 - 11:47

it may have been a bit bold of me to quote you, Jason, in my posting on the AMD forum, i hope its ok with you. I suggest that all of us who are AMD users go there and support my posting if you agree with its content.

here you go:
AMD forum Rise of Flight petition
  • 0

#27 buzzard1066

buzzard1066
  • Posts: 13

Posted 05 September 2011 - 12:22

Sorry Jason-
I quoted you too - I filed a technical support request with ATI/AMD. I read Zent's post and mine was similar. Basically, through their intransigence, ATI will lose a bunch of great customers who buy their high-end products. Hope you don't mind, at the very worst it will amount to nothing, at the very best maybe ATI will contact you guys, who knows?

cheers,
buzzard1066
  • 0

#28 buzzard1066

buzzard1066
  • Posts: 13

Posted 05 September 2011 - 12:29

Who knows, it might yield a positive result if people with ATI cards and problems with RoF filed similar technical support requests with AMD/ATI. I sent mine to http://emailcustomercare.amd.com/" onclick="window.open(this.href);return false;">http://emailcustomercare.amd.com/

hope it is not against RoF forum rules to advocate community action?

buzzard1066
  • 0

#29 ZaltysZ

ZaltysZ
  • Posts: 1638

Posted 05 September 2011 - 13:40

Probably the best way to secure driver support is to persuade benchmarking sites to include RoF into their benchmarks and reviews. It was a norm to see IL2 benchmarks 5 years or so ago. It would be nice to have the same with RoF, because that wouldn't allow driver devs to ignore RoF as that would result in poor benchmarks.
  • 0

#30 Zent

Zent
  • Posts: 111

Posted 05 September 2011 - 13:47

i was also posting the same text as in the forum as a driver feedback… lets shout on all channels !
  • 0

#31 SYN_Mike77

SYN_Mike77
  • Posts: 1161

Posted 05 September 2011 - 13:47

They did include ATI users in beta.
  • 0

#32 DidNotFinish

DidNotFinish
  • Posts: 4454

Posted 05 September 2011 - 13:51

Tried the new test settings and even though the starter says I'm getting 63% video memory usage, the stutters are terrible! I'll have to continue some of I'm own testing to see if ANYTHING can mitigate this.
  • 0

#33 DidNotFinish

DidNotFinish
  • Posts: 4454

Posted 05 September 2011 - 13:52

Remember a while ago that some MSSWFF2 sticks were causing stutter ?. I wonder if FF has anything to do with it.

I,ll fly with and without when I get back to my gaming PC tomorrow.

It can't be that because I (and a lot of others I'm sure) do have a FF stick. :?
  • 0

#34 Endy

Endy
  • Posts: 878

Posted 05 September 2011 - 14:36

Hi, unchecked Fullsceen, that worked for me.

Also, Jason mentioned in a previous post, Press F11 then look at the sun, then F1. That worked for me too last night, although I didn't check if it worked long term.

Thanks all for the suggestions. I didn't think I had a problem, until I flew in overcast conditions, Taxiing near hangers.
  • 0

#35 MAXV88

MAXV88
  • Posts: 78

Posted 05 September 2011 - 16:07

Hello everyone.
I noticed a lot of posts about stuttering in ROF.
I do not have any problems with it but I noticed
that I never started ROF without Tuneup Utilities Turbo Mode.
It is a software for optimization of the operating system.
I use it for games in which I want to get maximum.
Then few days ago I tried Rof without it just to see what happens
and game is almost unplayable (massive stuttering).
It would be interesting if someone else can confirm this.
Perhaps it might be possible to manually make these optimization tricks permanent.
I used this program with many other games but never noticed so big difference.
Maybe this can be a waypoint where to look for further optimization?

My comp.: Microsoft Windows 7 Ultimate x64 Service Pack 1
QuadCore AMD Phenom II X4 B45, 3333 MHz (15.5 x 215)
ASRock 880G Extreme3
AMD Radeon HD 6850 (Barts)
8192 MB (DDR3-1333 DDR3 SDRAM)
My ROF settings:

Image
  • 0

#36 Gwanchos

Gwanchos
  • Posts: 86

Posted 05 September 2011 - 18:00

Hi Devs

Just to confirm having been forced to update I too have bad stutters at low level. Option 1 (reduce FPS) does not work. I dont find the other options acceptable so for me I cannot use the game for now.

Its extremely frustrating that you wont allow people to roll back to the previous version. I always backup the whole directory before a patch on your instructions for just such an issue.

Very disappointed
  • 0

#37 SYN_Mike77

SYN_Mike77
  • Posts: 1161

Posted 05 September 2011 - 18:24

The two changes that I made that have stopped 95% of the stutters:

1. Uncheck full screen mode
2. turn shadows off.

With those two changes the game is quite playable. Try tohse gwanchos. I can't tell a visual difference between the full screen mode on or off and while I miss the shadows they are not a game breaker, at least to me.
  • 0

#38 AndrewHart

AndrewHart
  • Posts: 69

Posted 05 September 2011 - 18:46

Jason wrote 2A. Option #1: Lock your FPS at 30 and check on SLI/Crossfire box even if you have a single ATI card. Some users have been using the record function of FRAPS with frame lock on to limit frames to 30, but you do not need to do this, simply lock then in the ROF settings. My in game settings are this:

I'm just catching up on the latest developments with this and just wondering if I understand this properly – I used FRAPS just to record and not to limit my frames .. I run stutter-free just by perfoming the video capture in FRAPS .. I set FPS to unlimited in ROF settings and don't use FRAPS to lock frames.. and it's all good…As soon as I stop recording, the stutter returns

I've tried all other suggestions but no joy !!

Hope this helps
  • 0

#39 JoeCrow

JoeCrow
  • Posts: 4150

Posted 05 September 2011 - 19:07

The two changes that I made that have stopped 95% of the stutters:

1. Uncheck full screen mode
2. turn shadows off.

With those two changes the game is quite playable. Try tohse gwanchos. I can't tell a visual difference between the full screen mode on or off and while I miss the shadows they are not a game breaker, at least to me.

I don't think that there is a visual difference if both the screen and game resolutions are the same. It also works for me. So does Jason's suggestion of limiting fps to 30 and checking multi-gpu in fullscreen mode.
Cheers.
  • 0

#40 Gwanchos

Gwanchos
  • Posts: 86

Posted 05 September 2011 - 19:33

The two changes that I made that have stopped 95% of the stutters:

1. Uncheck full screen mode
2. turn shadows off.

With those two changes the game is quite playable. Try tohse gwanchos. I can't tell a visual difference between the full screen mode on or off and while I miss the shadows they are not a game breaker, at least to me.
ok thanks Will give that a try …. Im assuming here that these are temp measures tho ??
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users